#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?xsm)" & @CRLF & _
"(.+) # copy-past replacement to "
Local $sString = "=IFERROR(" & @CRLF & _
" MAX(" & @CRLF & _
" INDEX(" & @CRLF & _
" raw_wells_prod!R1," & @CRLF & _
" MATCH(" & @CRLF & _
" 1," & @CRLF & _
" raw_wells_prod!R," & @CRLF & _
" 0" & @CRLF & _
" )" & @CRLF & _
" )," & @CRLF & _
" INDEX(" & @CRLF & _
" raw_wells_inj!R1," & @CRLF & _
" MATCH(" & @CRLF & _
" 1," & @CRLF & _
" raw_wells_prod!R," & @CRLF & _
" 0" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )," & @CRLF & _
" 0" & @CRLF & _
") "
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)