import re
regex = re.compile((r"(?xsm)\n"
r"(.+) # copy-past replacement to "), flags=re.MULTILINE)
test_str = ("=IFERROR(\n"
" MAX(\n"
" INDEX(\n"
" raw_wells_prod!R1,\n"
" MATCH(\n"
" 1,\n"
" raw_wells_prod!R,\n"
" 0\n"
" )\n"
" ),\n"
" INDEX(\n"
" raw_wells_inj!R1,\n"
" MATCH(\n"
" 1,\n"
" raw_wells_prod!R,\n"
" 0\n"
" )\n"
" )\n"
" ),\n"
" 0\n"
") ")
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)