#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)\d+\t\v\s\v.+\v(.+)\t(.+)\s\v(.+)\s€\s\d+,\d+\v\d+"
Local $sString = "pos Désignation article " & @CRLF & _
"articles N° d'origine " & @CRLF & _
"Fabricant Prix net H.T " & @CRLF & _
"commandé(e) " & @CRLF & _
"livré(s) remise Texte de la commande Prix " & @CRLF & _
"mise au rebut " & @CRLF & _
"1 " & @CRLF & _
" " & @CRLF & _
"PLATINE, AUDIO RECORDER " & @CRLF & _
"F192103 996510063444 " & @CRLF & _
"GIBSON/PHILIPS € 25,17" & @CRLF & _
"2" & @CRLF & _
"2 0 %" & @CRLF & _
"€ 0,00 S0630500245392 P000767686 € 55,34" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"2 " & @CRLF & _
" " & @CRLF & _
"ASSY-MAIN BOARD HTL316 " & @CRLF & _
"G922573 996580008736 " & @CRLF & _
"GIBSON/PHILIPS € 12,80" & @CRLF & _
"3" & @CRLF & _
"3 0 %" & @CRLF & _
"€ 0,00 S0630005248395 P000567585 € 38,40" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"3 " & @CRLF & _
" " & @CRLF & _
"3300UF25V CHIMI. RADI 105GRAD6X25 " & @CRLF & _
"3369044 " & @CRLF & _
"€ 0,65" & @CRLF & _
"20" & @CRLF & _
"20 0 %" & @CRLF & _
"€ 0,00 S0630005548392 P005767586 € 13,00" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"4 " & @CRLF & _
" " & @CRLF & _
"MOTOR DC <=37.5W " & @CRLF & _
"F629401 996580001916 " & @CRLF & _
"GIBSON/PHILIPS € 7,71" & @CRLF & _
"1" & @CRLF & _
"0 0 %" & @CRLF & _
"€ 0,00 S0630000548352 P005765686 € 0,00" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" cet article vous parviendra ultérieurement dans u colis séparé " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"5 " & @CRLF & _
" " & @CRLF & _
"MECH. UNIT, DVD PLAYER " & @CRLF & _
"F192078 996510059018 " & @CRLF & _
"GIBSON/PHILIPS € 9,95" & @CRLF & _
"1" & @CRLF & _
"1 0 %" & @CRLF & _
"€ 0,00 S0630000548392 P005767686 € 9,95" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"6 " & @CRLF & _
" " & @CRLF & _
"MECANIQUE DVD " & @CRLF & _
"F192541 996510066471 " & @CRLF & _
"GIBSON/PHILIPS € 18,50" & @CRLF & _
"19" & @CRLF & _
"19 0 %" & @CRLF & _
"€ 0,00 S0630000255392 P000765686 € 351,50" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"7 " & @CRLF & _
" " & @CRLF & _
"MAIN+DC+USB+WIFI SOCKE " & @CRLF & _
"G813754 996580007956 " & @CRLF & _
"GIBSON/PHILIPS € 79,25" & @CRLF & _
"1" & @CRLF & _
"0 0 %" & @CRLF & _
"€ 0,00 S0630000248352 P000757686 € 0,00" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"8 " & @CRLF & _
" " & @CRLF & _
"BROSSE COMBINÉ " & @CRLF & _
"G787239 140030390060 " & @CRLF & _
"ELECTROLUX € 29,77" & @CRLF & _
"1" & @CRLF & _
"1 15 %" & @CRLF & _
"€ 4,47 R002788521 P000755686 € 25,30" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"9 " & @CRLF & _
" " & @CRLF & _
"ACCU 22,2V " & @CRLF & _
"D436440 91708307 " & @CRLF & _
"DYSON € 29,75" & @CRLF & _
"1" & @CRLF & _
"1 15 %" & @CRLF & _
"€ 4,46 R002756551 P000767686 € 25,29" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"10 " & @CRLF & _
" " & @CRLF & _
"RESSORT DE CUVE " & @CRLF & _
"G958435 43011062 " & @CRLF & _
"GROUPE CANDY € 4,50" & @CRLF & _
"1" & @CRLF & _
"1 15 %" & @CRLF & _
"€ 0,68 R002792326 P000767686 261177 € 3,82" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"11 " & @CRLF & _
" " & @CRLF & _
"REGENERATION UNIT " & @CRLF & _
"D18109 1741600500 " & @CRLF & _
"€ 6,95" & @CRLF & _
"1" & @CRLF & _
"1 20 %" & @CRLF & _
"€ 1,39 R002788169 P000767686 11872 € 5,56" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"12 " & @CRLF & _
" " & @CRLF & _
"POMPE DE VIDANGE ASKOLL 6353334W " & @CRLF & _
"5878082 91200173 " & @CRLF & _
"GROUPE CANDY € 22,75" & @CRLF & _
"1" & @CRLF & _
"1 15 %" & @CRLF & _
"€ 3,41 R002788982 P000767686 11913 € 19,34" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"13 " & @CRLF & _
" " & @CRLF & _
"PRESSOSTAT " & @CRLF & _
"Y53031 DC9601703B " & @CRLF & _
"SAMSUNG € 22,95" & @CRLF & _
"1" & @CRLF & _
"1 0 %" & @CRLF & _
"€ 0,00 R002789006 P000767686 12156 € 22,95" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"14 " & @CRLF & _
" " & @CRLF & _
"016912 RÉSISTANCE DE SOLE 1300W FAGORCA50042A9 " & @CRLF & _
"F289696 " & @CRLF & _
"€ 22,35" & @CRLF & _
"1" & @CRLF & _
"1 0 %" & @CRLF & _
"€ 0,00 R002789196 P000767686 11966 € 22,35" & @CRLF & _
"€ 0,00 ouvre la page détaillée de l'article avec la quantité commandée et les références par position " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"total" & @CRLF & _
"Vous avez commandé 14 articles au prix de € 555,55" & @CRLF & _
"Frais de recyclage € 0,00" & @CRLF & _
"Frais de port € 0,00" & @CRLF & _
"20,00 % TVA € 555,55" & @CRLF & _
" " & @CRLF & _
"Montant de la facture € 555,55" & @CRLF & _
"Vue avant impression"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")