package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?\d+\.?\d*`)
var str = `-1
0
10.0
+10
-10
-10.0
+10.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}