$re = '/^[-+]?\d+\.?\d*/m';
$str = '-1
0
10.0
+10
-10
-10.0
+10.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);