$re = '/<a.*?example.*?\/a>/';
$str = 'vcn<a href="http://example.com">1rer</a>vcbn
<a href="http://example.com/fdfdsfds">fdsfsdfsd</a>cvbn
cvbn<a class="fff" href="http://example.com/dsdaas">3e2fdf fdsfds</a>cvbn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);