import Foundation
let pattern = #"<a.*?example.*?\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
vcn<a href="http://example.com">1rer</a>vcbn
<a href="http://example.com/fdfdsfds">fdsfsdfsd</a>cvbn
cvbn<a class="fff" href="http://example.com/dsdaas">3e2fdf fdsfds</a>cvbn
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)