$re = '/^\\\\w+([\\\\.-]?\\\\w+)*@\\\\w+([\\\\.-]?\\\\w+)*(\\\\.\\\\D{2,3})+$/m';
$str = 'reshmi@greenlab.diamonds';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;