re = /^\\w+([\\.-]?\\w+)*@\\w+([\\.-]?\\w+)*(\\.\\D{2,3})+$/m
str = 'reshmi@greenlab.diamonds'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result