const regex = /^(?!.*(?:tree|car|ship)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(?:tree|car|ship)).*$', 'gm')
const str = `a1testtre
orangesh1
apleship3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}