$re = '/^(?!.*(?:tree|car|ship)).*$/m';
$str = 'a1testtre
orangesh1
apleship3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);