package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s\d]*\d\S*`)
var str = `ABCD abcd AB55 55CD A55D 5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}