$re = '/[^\s\d]*\d\S*/m';
$str = 'ABCD abcd AB55 55CD A55D 5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);