$re = '/(?<!\S)[:.][\w+-]+/m';
$str = '.snippet1 Lorem ipsum :snippet2 dolor sit amet .snippet3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);