re = /(?<!\S)[:.][\w+-]+/m
str = '.snippet1 Lorem ipsum :snippet2 dolor sit amet .snippet3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end