use strict;
my $str = ' Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
real ';
my $regex = qr/(^\s*)(.+)((?<=\w)\s*$)/mp;
my $subst = '\\U\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";