using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s+)qwe45rty(?=\s+|$)";
string input = @"qwe45rty qwe45rty qwe45rty qwe45rty qwe45rty qwe45rty";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}