re = /(^|\s+)qwe45rty(?=\s+|$)/
str = 'qwe45rty qwe45rty qwe45rty qwe45rty qwe45rty qwe45rty'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end