#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}$"
Local $sString = "22" & @CRLF & _
"11," & @CRLF & _
",11," & @CRLF & _
"1,123,344,32" & @CRLF & _
"" & @CRLF & _
"12.234" & @CRLF & _
"234.45" & @CRLF & _
"33333.3333" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"1233333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")