$re = '/^\d{1,2}$/m';
$str = '22
11,
,11,
1,123,344,32
12.234
234.45
33333.3333
123
1233333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);