# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|>)[^<]+/$1/gm;t' <<< "abcd<App>ew <View id=\"view1\" visible=\"true\">4</View>- <View id=\"view1\" visible=\"true\" width=\"100\">WORD</View>s</App>abcd"