// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|>)[^<]+").unwrap();
let string = "abcd<App>ew <View id=\"view1\" visible=\"true\">4</View>- <View id=\"view1\" visible=\"true\" width=\"100\">WORD</View>s</App>abcd";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}