$re = '/^/?category/([A-Za-z0-9-]+)/([^/d]+)/?$/';
$str = '/badar/category/produkunggulan/CT0002/
/badar/category/produkunggulan/CT0002/blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);