re = /^\/?category\/([A-Za-z0-9-]+)\/([^\/d]+)\/?$/
str = '/badar/category/produkunggulan/CT0002/
/badar/category/produkunggulan/CT0002/blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end