using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]{2,}\!?) ([^(]+)(?<!\s) ?(?<BR>\()?((?(BR)[^\)]+))(?(BR)(\)))$";
string input = @"PREFIX description goes here (optional)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}