package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:I|US|TX)-\d{1,3} \w+`)
var str = `I-35 South / US-290 West`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}