#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!-|_|\d)\w+(?<!\db)-v\d+\.\d+-\w+-v\d+\.\d+(-\d+b-\w+|-\d+x\d+b-\w+-*|-\d+b-\w+-.*|-\w+-\d+b|-\w+-\w+-.*)"
Local $sString = "Should match." & @CRLF & _
"" & @CRLF & _
"BaseModelName-v0.3-ModelName-v0.3-8x7b-Method-Q4_0" & @CRLF & _
"BaseModelName-v0.4-ModelName-v12.2-2x7b-Method-QQ4_k_m" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-qq4_k_m" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-Qq4_k_m" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-qQ4_k_m" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-IQ4_S" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-IQ4_XS" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-IQ4_XXS" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-Q4" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x7b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x0.7b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-2x0.77b-Method" & @CRLF & _
"BaseModelNameb-v0.4-ModelName-v1.2-2x7b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-7b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-0.7b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-700M-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-70M-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-7M-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-0.7M-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-723b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-7000b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-7000b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.222222222-7000b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.0-7000b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1-7000b-Method" & @CRLF & _
"BaseModelName-v0.4-ModelName-v1.2-Method-7b" & @CRLF & _
"Missingdashbetweenmethodandquantizationformat-v0.4-ModelName-v1.2-2x7b-MethodQ4_K_M" & @CRLF & _
"Llama-v3.0-Hermes-v2.0-7b-instruct-DPO-Q4_0.gguf" & @CRLF & _
"Llama-v3.0-Hermes-v2.0-instruct-DPO-7b-Q4_0.gguf" & @CRLF & _
"Llama-v3.0-Hermes-v2.0-7b-4k-Instruct-Merged-DPO-Q4_0" & @CRLF & _
"" & @CRLF & _
"Mixtral-8x7b-Q5_K_M-instruct-v0.1.gguf" & @CRLF & _
"Mixtral-8x7b-instruct-v0.1-Q5_K_M.gguf" & @CRLF & _
"Hermes-2-Theta-Llama-3-8B" & @CRLF & _
"SOLAR-10.7B-Instruct-v1.0" & @CRLF & _
"" & @CRLF & _
"Deviation from the pattern." & @CRLF & _
"" & @CRLF & _
".StartModelNameWithNon_AlphaNumeric-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"9StartModelNameWithNumber-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"_StartModelNameWithUnderScore-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"-StartModelNameWithDash-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"Missingdashv0.4-ModelName-v0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"Missingdash-v0.4ModelName-v0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"Missingdash-v0.4-ModelNamev0.2-2x7b-Method-Q4_K_M" & @CRLF & _
"Missingdash-v0.4-ModelName-v0.22x7b-Method-Q4_K_M" & @CRLF & _
"Missingdash-v0.4-ModelName-v0.2-2x7bMethod-Q4_K_M" & @CRLF & _
"MissingParameterCount-v0.4-ModelName-v0.2-Method" & @CRLF & _
"MissingMethod-v0.4-ModelName-v0.2-7b" & @CRLF & _
"MissingMethod-v0.4-ModelName-v0.2-7b-" & @CRLF & _
"MissingMethod-v0.4-ModelName-v0.2-8x7b" & @CRLF & _
"MissingMethod-v0.4-ModelName-v0.2-8x7b-" & @CRLF & _
"Missing_v_afterdash-0.4-ModelName-v0.2-2x7b-Method-QQ4_K_M" & @CRLF & _
"BaseModelnamecontainsdash_phi-3-v0.4-Modelname-v0.2-2x7b-Method-IQ4_XXS" & @CRLF & _
"BaseModelnamecontainsParameterCount_phi37b-v0.4-Modelname-v0.2-2x7b-Method-IQ4_XXS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")