import Foundation
let pattern = #"^(?!-|_|\d)\w+(?<!\db)-v\d+\.\d+-\w+-v\d+\.\d+(-\d+b-\w+|-\d+x\d+b-\w+-*|-\d+b-\w+-.*|-\w+-\d+b|-\w+-\w+-.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should match.
BaseModelName-v0.3-ModelName-v0.3-8x7b-Method-Q4_0
BaseModelName-v0.4-ModelName-v12.2-2x7b-Method-QQ4_k_m
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-qq4_k_m
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-Qq4_k_m
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-qQ4_k_m
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-IQ4_S
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-IQ4_XS
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-IQ4_XXS
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-Q4
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method-
BaseModelName-v0.4-ModelName-v1.2-2x7b-Method
BaseModelName-v0.4-ModelName-v1.2-2x0.7b-Method
BaseModelName-v0.4-ModelName-v1.2-2x0.77b-Method
BaseModelNameb-v0.4-ModelName-v1.2-2x7b-Method
BaseModelName-v0.4-ModelName-v1.2-7b-Method
BaseModelName-v0.4-ModelName-v1.2-0.7b-Method
BaseModelName-v0.4-ModelName-v1.2-700M-Method
BaseModelName-v0.4-ModelName-v1.2-70M-Method
BaseModelName-v0.4-ModelName-v1.2-7M-Method
BaseModelName-v0.4-ModelName-v1.2-0.7M-Method
BaseModelName-v0.4-ModelName-v1.2-723b-Method
BaseModelName-v0.4-ModelName-v1.2-7000b-Method
BaseModelName-v0.4-ModelName-v1.2-7000b-Method
BaseModelName-v0.4-ModelName-v1.222222222-7000b-Method
BaseModelName-v0.4-ModelName-v1.0-7000b-Method
BaseModelName-v0.4-ModelName-v1-7000b-Method
BaseModelName-v0.4-ModelName-v1.2-Method-7b
Missingdashbetweenmethodandquantizationformat-v0.4-ModelName-v1.2-2x7b-MethodQ4_K_M
Llama-v3.0-Hermes-v2.0-7b-instruct-DPO-Q4_0.gguf
Llama-v3.0-Hermes-v2.0-instruct-DPO-7b-Q4_0.gguf
Llama-v3.0-Hermes-v2.0-7b-4k-Instruct-Merged-DPO-Q4_0
Mixtral-8x7b-Q5_K_M-instruct-v0.1.gguf
Mixtral-8x7b-instruct-v0.1-Q5_K_M.gguf
Hermes-2-Theta-Llama-3-8B
SOLAR-10.7B-Instruct-v1.0
Deviation from the pattern.
.StartModelNameWithNon_AlphaNumeric-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M
9StartModelNameWithNumber-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M
_StartModelNameWithUnderScore-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M
-StartModelNameWithDash-v0.4-Anothername-v0.2-2x7b-Method-Q4_K_M
Missingdashv0.4-ModelName-v0.2-2x7b-Method-Q4_K_M
Missingdash-v0.4ModelName-v0.2-2x7b-Method-Q4_K_M
Missingdash-v0.4-ModelNamev0.2-2x7b-Method-Q4_K_M
Missingdash-v0.4-ModelName-v0.22x7b-Method-Q4_K_M
Missingdash-v0.4-ModelName-v0.2-2x7bMethod-Q4_K_M
MissingParameterCount-v0.4-ModelName-v0.2-Method
MissingMethod-v0.4-ModelName-v0.2-7b
MissingMethod-v0.4-ModelName-v0.2-7b-
MissingMethod-v0.4-ModelName-v0.2-8x7b
MissingMethod-v0.4-ModelName-v0.2-8x7b-
Missing_v_afterdash-0.4-ModelName-v0.2-2x7b-Method-QQ4_K_M
BaseModelnamecontainsdash_phi-3-v0.4-Modelname-v0.2-2x7b-Method-IQ4_XXS
BaseModelnamecontainsParameterCount_phi37b-v0.4-Modelname-v0.2-2x7b-Method-IQ4_XXS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)