package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<code>\d+)?.*?(?P<name>[A-Za-z]+)`)
var str = `GERI
24£JTR
78£TDE
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}