$re = '/(?P<code>\d+)?.*?(?P<name>[A-Za-z]+)/m';
$str = 'GERI
24£JTR
78£TDE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);