import re
regex = re.compile(r"(((у|я|о)н(и|ц)?(ов)?)|(ци?))\b", flags=re.MULTILINE)
test_str = ("Оганян\n"
"Яндарбиев\n"
"Геворгянц\n"
"Маштоц\n"
"Гурунц\n"
"Адонц\n"
"Багратуни\n"
"Месроп Маштоц проверят границу слова\n"
"Меликоянов\n"
"Малоямпольский\n"
"Давид Сасунский\n"
"Мовсес Хоренаци\n"
"Арам Габрелянов\n"
"Воротнеци\n"
"Харкаци\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")