using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Height|Width|Depth|Weight)\s{0,4}(?::|-)\s{0,4}([0-9\.]{1,})(mm|cm|Kg)";
string input = @"Height : 435mm Width : 700mm Depth : 50cm Weight : 7.60Kg";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}