// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(Height|Width|Depth|Weight)\s{0,4}(?::|-)\s{0,4}([0-9\.]{1,})(mm|cm|Kg)").unwrap();
let string = "Height : 435mm Width : 700mm Depth : 50cm Weight : 7.60Kg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}