package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+,?\d{0,2}$`)
var str = `5
5,
5,0
5,00
5,000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}