$re = '/^\d+,?\d{0,2}$/m';
$str = '5
5,
5,0
5,00
5,000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);