$re = '/^[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+(?:\s[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+)?\s[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+(?:-[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+)?$/m';
$str = 'Jan Maria Rokita
Jan Władysław Rokita
Jan Kowalski
Edward Ącki
Joanna Kluzik-Rostkowska
Joanna Grażyna Kluzik-Rostkowska
Maria Curie-Skłodowska
Anna Maria Jopek
Jan Heweliusz
Covax Shaw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);