re = /^[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+(?:\s[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+)?\s[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+(?:-[A-PR-UWY-ZĄĆĘŁŃÓŚŹŻ][a-pr-uwy-ząćęłńóśźż]+)?$/m
str = 'Jan Maria Rokita
Jan Władysław Rokita
Jan Kowalski
Edward Ącki
Joanna Kluzik-Rostkowska
Joanna Grażyna Kluzik-Rostkowska
Maria Curie-Skłodowska
Anna Maria Jopek
Jan Heweliusz
Covax Shaw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end