$re = '/\/[\w-]+[^-]$/m';
$str = 'asdasd/hello-
asdasd/hel-oo
asdasd/hello-oo-
asdasd/hello-oo-oo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);