re = /\/[\w-]+[^-]$/m
str = 'asdasd/hello-
asdasd/hel-oo
asdasd/hello-oo-
asdasd/hello-oo-oo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end