package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)(<(?:[^<>]++|(?2))*>)`)
var str = `QMap<QgsFeatureId, QPair<QMfap<Something, Complex> >>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}