re = /(\w+)(<(?:[^<>]++|(?2))*>)/
str = 'QMap<QgsFeatureId, QPair<QMfap<Something, Complex> >>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end