// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*odh.*develop|feature.*").unwrap();
let string = "AXAes-engineering-office/ODH_new/build_ODH/axaes-odh-catalog/develop
ODH/odh_jobs/axaes-odh-client/feature/test-regex";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}