import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\u4E00-\\u9FFF\\u3400-\\u4DBF\\uF900-\\ufaff\\u3040-\\u309f\\u30a0-\\u30ff\\u3000-\\u303f\\uff21-\\uff3a\\uff41-\\uff5a\\uff10-\\uff19\\uff00-\\uff0eA-Za-z0-9@.,;!\\? ~♥\\\\]*)(?P<match>(?:[^\\u4E00-\\u9FFF\\u3400-\\u380f\\uF900-\\ufaff\\u3040-\\u309f\\u30a0-\\u30ff\\u3000-\\u303f\\uff21-\\uff3a\\uff41-\\uff5a\\uff10-\\uff19A-Za-z0-9\\r\\n]|[人・;皿。゜°うぅ]){3,})(?:[\\u4E00-\\u9FFF\\u3400-\\u4DBF\\uF900-\\ufaff\\u3040-\\u309f\\u30a0-\\u30ff\\u3000-\\u303f\\uff21-\\uff3a\\uff41-\\uff5a\\uff10-\\uff19A-Za-z0-9@.,; ~♥\\\\]*)";
final String string = "ふう。お腹いっぱい( ´•౪•`), 試験頑張るぞ\\\\\\ ٩( ‘ω’ )و ////\n"
+ "心の相談は メール tiknathan@mail.goo.ne.jp までご連絡ください\n"
+ "ドーピング系浪人生(n=1)\n"
+ "横浜は関内にある「 BWY らっきょ 」に初訪問してまいりました関東スープカレーブームの火付け役となったお店の「 人気NO.1 チキンカレー 」をいただきました(´∀`人)\n"
+ "鳥取県倉吉市 倉吉農業高校 3年食品科 (音楽部・茶道部) AKB48大ファン高校生!まゆゆ、中野郁海ちゃん神推し m0326w。♥。・゚♡゚・。♥。i0820n~現在♥大好きだよ♥ AKBファンの方はフォローお願いします^-^ \\n\\n来春から新社会人・・・の予定(´・ω・`) nn(。´-д-)疲れた。。";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}