const regex = new RegExp('(?:[\\u4E00-\\u9FFF\\u3400-\\u4DBF\\uF900-\\ufaff\\u3040-\\u309f\\u30a0-\\u30ff\\u3000-\\u303f\\uff21-\\uff3a\\uff41-\\uff5a\\uff10-\\uff19\\uff00-\\uff0eA-Za-z0-9@.,;!\\? ~♥\\\\]*)(?P<match>(?:[^\\u4E00-\\u9FFF\\u3400-\\u380f\\uF900-\\ufaff\\u3040-\\u309f\\u30a0-\\u30ff\\u3000-\\u303f\\uff21-\\uff3a\\uff41-\\uff5a\\uff10-\\uff19A-Za-z0-9\\r\\n]|[人・;皿。゜°うぅ]){3,})(?:[\\u4E00-\\u9FFF\\u3400-\\u4DBF\\uF900-\\ufaff\\u3040-\\u309f\\u30a0-\\u30ff\\u3000-\\u303f\\uff21-\\uff3a\\uff41-\\uff5a\\uff10-\\uff19A-Za-z0-9@.,; ~♥\\\\]*)', 'gm')
const str = `ふう。お腹いっぱい( ´•౪•\`), 試験頑張るぞ\\\\\\ ٩( ‘ω’ )و ////
心の相談は メール tiknathan@mail.goo.ne.jp までご連絡ください
ドーピング系浪人生(n=1)
横浜は関内にある「 BWY らっきょ 」に初訪問してまいりました関東スープカレーブームの火付け役となったお店の「 人気NO.1 チキンカレー 」をいただきました(´∀`人)
鳥取県倉吉市 倉吉農業高校 3年食品科 (音楽部・茶道部) AKB48大ファン高校生!まゆゆ、中野郁海ちゃん神推し m0326w。♥。・゚♡゚・。♥。i0820n~現在♥大好きだよ♥ AKBファンの方はフォローお願いします^-^ \\n\\n来春から新社会人・・・の予定(´・ω・`) nn(。´-д-)疲れた。。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}