package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)___([a-zA-Z_]*)___`)
var str = `___string_string___
___test___
__something__
___sda1231___`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}