const regex = /___([a-zA-Z_]*)___/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('___([a-zA-Z_]*)___', 'gm')
const str = `___string_string___
___test___
__something__
___sda1231___`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}