package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?\d+\.?(\d+)?([eE][+-]?\d+)?$`)
var str = `42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}