$re = '/^-?\d+\.?(\d+)?([eE][+-]?\d+)?$/m';
$str = '42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;