# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w_]+):([a-zA-Z]\w*)/$1:"$2"/gm;t' <<< "{Sensor_id:2.4,locationIP:2.2,Sensor_value:A}"