$re = '/([\w_]+):([a-zA-Z]\w*)/m';
$str = '{Sensor_id:2.4,locationIP:2.2,Sensor_value:A}';
$subst = "$1:\"$2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;